Introducing TheirLabel: domain name white-labeling for Bubble

Bubble is a technology I've come to love. The ethos behind its creation - that you shouldn't have to have a PhD in computer science to build a custom website - is exciting, democratic, and empowering. There's a lot of great design in this product. To list a few, I'm really impressed by the automatically provisioned API one gets the second after you create a new app. Its built in authentication and rule based permissioning is a breeze to work with. Want to change the name of a key in your database? Okay, that key name has been automatically updated across the 56 places you've used it in your application logic! Want to secure your site? Press a button and it's done. All of these things, and many others, crush the core hurdles that stop even seasoned programmers from making sophisticated websites.


This is a companion discussion topic for the original entry at https://blog.scious.io/theirlabel/

Great job ! Thanks I am implementing it.
I was wondering if we could customize the favicon ?

Thank you.

Regards,

1 Like

Hello jbraoude, thank you for your message! Yes, we can definitely add this. I will personally look into this tomorrow. Will let you know when it’s available, thanks!

1 Like

Amazing. Thank you :slightly_smiling_face:

Hey jbraoude, I have updated TheirLabel to enable custom favicons. To use this functionality, please upgrade your plugin to version 1.3.3. Then, you will see that the “Update white label” action now has a favicon_url field in which you can (optionally) add your favicon url:

image

Let me know how it goes. Cheers!

Hello @aagostini,

How are you ?
As the idea is to use your solution in a SAS solution. I would like to avoid asking the client to add CNAME record showing a "netlify . app . ". My first idea was to :

  1. let the clients create a subdomain on my domain : clientsubdomain . mydomain . com by creating a new record in my DNS with : Name (host) is cleintdomain and Value is : “clientdomain . netifly . app”

  2. Ask the client to create a record in his DNS with type : CNAME / host : clientsubdomain / value : “clientsubdomain . mydomain . com”

But it did not worked.

I thought it may working asking the client to create a new record with type : A / host : clientsubdomain / value : “netilfyIP”.

Is it possible to find this netiflyIP ?

Or do you have any idea how to avoid asking the client to add CNAME record showing a “netlify(.app” ?

I hope this is clear.

Please let me know.

PS : do you see any possibilites to add path “/” in URL like it seems to be possible on : https://www.notion.so/SaasAlias-412cc92625e14f2b9658c61fdf53fae3 ?

Thank you very much

Best regards,
Jonas

Hello Jonas, thank you for your message :slight_smile:

I see what you are trying to do and I like your style - ideally I would be able to do the same. Unfortunately, I don’t believe this is possible with this plugin. The CNAME records provided are our only options.

I address/explain some of these shortfalls in more detail here. The jest of it is that Bubble really needs to make this functionality a native feature. Plugins like mine are really just a best attempt to fill a gap.

Hello @aagostini

Got an issue that didn’t experience since now.
Capture d’écran 2021-05-26 à 12.39.13

Are you aware of this issue ? Is it a bug ? I d’ont think I changed anything since it was working.

Please let me know.

best regards,

Jonas

Hello Jonas - thank you for your message and I apologize for the inconvenience. Are you still seeing this issue? To your question, I haven’t seen this.

What did you do / what is your app in the middle of doing when this occurs?

Hello @aagostini,

Yes I am still seing this.

I tested https://www.theirlabel.com/ and also got an error.

I noticed that it only happen with my domain businesskorners .com
Anything.businesskorners . com don’t work (while I am sure it used to work)
anything.anything. com works

Do you have any idea why ?

Best regards,

I know exactly what happened - essentially your domain businesskorners.com was still registered with my demo app, and so using it in your app threw a form of Non Unique Site Name error on Netlify. I have manually released your domain name from my demo site, and so this issue should disappear immediately. Please let me know if that is not the case. Thanks!

Thanks for answering quickly. Unfortunatly not, I have just tested from my app and still got the same issue. Should I test on theirlabel.com ?

Regards,

No, do not test this on theirlabel.com as that would only reinforce the issue (by creating another copy of the domain you’re already trying to set).

I’ve taken a look at the demo sites and have removed any related to businesskorners.com. It appears that the duplication is happening on your side. Essentially, you have already created a particular whitelable, and it looks like you’ve somehow created it again or are trying to.

One must delete a white label using TheirLabels delete whitelable action before attempting to create that whitelable again. You will need to log into your Netlify account and manually delete the infringing whitelable (which is called a site in Netlify’s dashboard).

You can do this by going to site settings for the duplicate site

And clicking DELETE under the Danger Zone Tab

Thank you @aagostini . It is really strange because I am sure the URL I try to create doesn’t exist.
I thought may be I reached a maximum so I deleted few tests site.
And now when I attempt to create I have an other error : Error 401 with no other indications.

Any ideas ?

Regards,

Jonas

Just to make sure - is your installed version of TheirLabel on the latest version? It believe it should be version 1.3.3.

Yes I confirm. I am on 1.3.3

Hmm, I’m scratching my head on this one. Perhaps we can schedule a time to have you walk me through your setup. That may be the quickest way to diagnose what’s happening here. Please let me know if that is still needed by direct messaging me here in the forum (as I’m sure you do not want to sure your contact information on this public discussion board).

Thank you jbraoude and I apologize again for the inconvenience.

1 Like

Thank you for investigating :slight_smile: Not sure I have permission to send direct message.
May be you can engage the conversation on your side. Thank you very much.

Regards,

Jonas

Sorry, I should have just sent you a direct message. I just did that - let me know of a good time we can review in the DM! Thanks

Hello There,
Tried on TestDrive, before I go for the plugin. Its throwing some error “Ensure that your URLs have been entered correctly” for my domain name only.

For other domain name it generates the namespacess

Can you please help me what I am missing.